이더리움 하드포크 또 연기...보안 코드 결함 발견
이더리움 하드포크 또 연기...보안 코드 결함 발견
  • 김혜정 기자
  • 승인 2019.01.16 14:57
  • 댓글 0
이 기사를 공유합니다

[출처=셔터스톡]
[출처=셔터스톡]

이더리움 콘스탄트노플 하드포크가 재차 연기됐다. 코드에 취약점이 발견된 탓이다. 

15일(현지시간) 스마트 컨트랙트 감사업체 체인시큐리티(ChainSecurity)는 공식 블로그를 통해 "콘스탄티노플 업그레이드 코드에 예기치 않은 취약점을 발견했다"며 "업그레이드를 하기 전에는 안전하지만 (하드포크를) 하고 난 뒤에는 문제가 발생하는 코드"라고 밝혔다. 

체인시큐리티가 발견한 취약점은 재진입 공격(reentrancy attack)이다. 실행 중인 함수를 중복 입력할 수 있기 때문에 자금 인출 요청도 무한대로 할 수 있는 문제가 발생한다. 지난 2016년 다오(DAO) 해킹 사건 때도 이 같은 경로가 발견되면서 문제가 됐다.

소식을 접한 이더리움 개발자들은 전화 회의를 열어 하드포크를 미루는 것에 합의하고, 기존 비잔티움 소프트웨어에 하드포크가 발생하지 않도록 수정한 버전을 배포했다. 

허드슨 제임슨(Hudson Jameson) 이더리움 개발자는 "전체 블록 조사 결과 아직 피해 사례는 없으나 위험성이 아예 없는 것은 아니"라며 "채굴자 및 거래소, 노드 운영자는 소프트웨어를 업그레이드하기 바란다"고 당부했다.

당초 콘스탄티노플 하드포크는 지난해 11월로 예정돼 있었으나 테스트넷에서 버그가 발견돼 708만번째 블록으로 미뤄진 바 있다. 개발자들은 추가 회의를 거쳐 이번주 말쯤 새로운 하드포크 일정을 공개할 예정이다.
 


관련기사

댓글삭제
삭제한 댓글은 다시 복구할 수 없습니다.
그래도 삭제하시겠습니까?
댓글 0
댓글쓰기
계정을 선택하시면 로그인·계정인증을 통해
댓글을 남기실 수 있습니다.